VULNERABILITY INTELLIGENCE
CVE-2020-5263
CVSS score5.5 MEDIUM
EPSS probability0.87%
CISA KEVNot currently listed
Published2020-04-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
Description
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3
Weakness classification
- CWE-522: Insufficiently Protected Credentials
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory