VULNERABILITY INTELLIGENCE
CVE-2020-5216
CVSS score4.4 MEDIUM
EPSS probability1.21%
CISA KEVNot currently listed
Published2020-01-23
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.
Weakness classification
- security-advisories@github.com: CWE-113
- nvd@nist.gov: CWE-74
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Exploit, Mitigation, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Mitigation, Third Party Advisory