VULNERABILITY INTELLIGENCE

CVE-2020-5210

CVSS score5 MEDIUM
EPSS probability0.80%
CISA KEVNot currently listed
Published2020-01-28
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L

Description

In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.

Weakness classification

  • security-advisories@github.com: CWE-120
  • nvd@nist.gov: CWE-120

Primary references