VULNERABILITY INTELLIGENCE
CVE-2020-5209
CVSS score5 MEDIUM
EPSS probability0.81%
CISA KEVNot currently listed
Published2020-01-28
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
Description
In NetHack before 3.6.5, unknown options starting with -de and -i can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.
Weakness classification
- security-advisories@github.com: CWE-120
- nvd@nist.gov: CWE-120
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory