VULNERABILITY INTELLIGENCE

CVE-2020-25699

CVSS score7.5 HIGH
EPSS probability1.61%
CISA KEVNot currently listed
Published2020-11-19
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Weakness classification

  • CWE-863: Incorrect Authorization

Primary references