VULNERABILITY INTELLIGENCE

CVE-2020-15210

CVSS score6.5 MEDIUM
EPSS probability0.74%
CISA KEVNot currently listed
Published2020-09-25
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Weakness classification

  • CWE-20: Improper Input Validation
  • CWE-787: Out-of-bounds Write

Primary references