VULNERABILITY INTELLIGENCE

CVE-2020-15187

CVSS score3 LOW
EPSS probability1.52%
CISA KEVNot currently listed
Published2020-09-17
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N

Description

In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2. As a possible workaround make sure to install plugins using a secure connection protocol like SSL.

Weakness classification

  • security-advisories@github.com: CWE-74
  • nvd@nist.gov: NVD-CWE-Other

Primary references