VULNERABILITY INTELLIGENCE
CVE-2019-25078
CVSS score5.3 MEDIUM
EPSS probability0.45%
CISA KEVNot currently listed
Published2022-12-13
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Description
A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
Weakness classification
- cna@vuldb.com: CWE-119
- nvd@nist.gov: CWE-120
Primary references
- cna@vuldb.com — Patch
- cna@vuldb.com — Exploit, Issue Tracking, Third Party Advisory
- cna@vuldb.com — Release Notes
- cna@vuldb.com — Permissions Required, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Issue Tracking, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Release Notes
- af854a3a-2127-422b-91ae-364da2661108 — Permissions Required, Third Party Advisory