VULNERABILITY INTELLIGENCE
CVE-2019-11253
CVSS score7.5 HIGH
EPSS probability25.94%
CISA KEVNot currently listed
Published2019-10-17
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
Weakness classification
- CWE-20: Improper Input Validation
- CWE-776: Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')
Primary references
- jordan@liggitt.net — Third Party Advisory
- jordan@liggitt.net — Third Party Advisory
- jordan@liggitt.net — Third Party Advisory
- jordan@liggitt.net — Exploit, Issue Tracking, Mitigation, Third Party Advisory
- jordan@liggitt.net — Permissions Required
- jordan@liggitt.net — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Issue Tracking, Mitigation, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Permissions Required
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory