VULNERABILITY INTELLIGENCE

CVE-2018-1000524

CVSS score5.5 MEDIUM
EPSS probability1.21%
CISA KEVNot currently listed
Published2018-06-26
Last modified2026-06-17
CVSS vectorCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Description

miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.

Weakness classification

  • nvd@nist.gov: CWE-190

Primary references