VULNERABILITY INTELLIGENCE
CVE-2017-1000479
CVSS score8.8 HIGH
EPSS probability31.70%
CISA KEVNot currently listed
Published2018-01-03
Last modified2026-06-17
CVSS vectorCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.
Weakness classification
- nvd@nist.gov: CWE-352
Primary references
- cve@mitre.org — Exploit, Mailing List, Third Party Advisory
- cve@mitre.org — Issue Tracking, Vendor Advisory
- cve@mitre.org — Patch, Third Party Advisory
- cve@mitre.org — Patch, Third Party Advisory
- cve@mitre.org — Third Party Advisory
- cve@mitre.org — Exploit, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Mailing List, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Third Party Advisory